Customer cannot re-run a course as part of a Program of Courses

Incident Report for Xen Education

Postmortem

History

A customer attempted to create a program with 7 courses from their tenancy, but experienced an error.

It was identified that 4 of the courses were duplicates of the same master course and shared the same unique identifier in the generated copies, resulting in 3 out of 4 copies being invalid.

This was identified as sn edge case scenario which was not covered during development.

A fix was produced to ensure every copy contains a unique and incremental identifier.

The customer was able to create the Program. after the fix was deployed.

What was the incident’s duration?

The incident was identified by the customer on 8th February 2023 at 05:57 PM AEST. The fix was deployed to production by 9th February at 3 PM.

Were there any consequences or damages?

Course managers/ Content creators couldn’t create programs.

Is the incident resolved?

Yes. By changing the logic in courses copy.

What will prevent further similar incidents?

Implemented additional monitoring to to detect issues during the course copy creation, to alert the development team beforehand.

Implemented notification/log entry for program course creation, which keeps track of all the course rerun creation transactions and its outcomes. This allows customers to see the direct result of their action, and potential errors or missing items.

Posted Jun 25, 2024 - 17:35 AEST

Resolved

A customer reported that the Program of Courses rerun/sync feature wasn’t working as expected.
Posted Feb 08, 2023 - 17:30 AEDT