API failure when enrolling students

Incident Report for Xen Education

Postmortem

A update to the Xen API intended for a Premium customer was inadvertently deployed to another customer during a manual deployment by an engineer.

This deployment changed the parameters for the enrolment endpoint which affected the customer still using the legacy parameters.

The code was reverted for this customer a few days later.

This incident highlighted a failure in process, and implementing stronger safe-guards around allowing manual deployments.

Posted Jun 25, 2024 - 18:46 AEST

Resolved

A customer is not able to onboard students using the API.
Posted Feb 20, 2024 - 00:00 AEDT